KDE 16.12 for Leap 42.2 ?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

KDE 16.12 for Leap 42.2 ?

Martin Koller
Hi,

Looking for kmail I find nothing at all in http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_Leap_42.2/x86_64/

In the kmail OBS build log, I find:
 CMake Error at CMakeLists.txt:11 (find_package):
[   71s]   Could not find a configuration file for package "ECM" that is compatible
[   71s]   with requested version "5.28.0".
[   71s]
[   71s]   The following configuration files were considered but not accepted:
[   71s]
[   71s]     /usr/share/ECM/cmake/ECMConfig.cmake, version: 5.26.0

can that package also be updated, please ?

--
Best regards/Schöne Grüße

Martin
A: Because it breaks the logical sequence of discussion
Q: Why is top posting bad?

()  ascii ribbon campaign - against html e-mail
/\                        - against proprietary attachments

Geschenkideen, Accessoires, Kulinarisches: www.lillehus.at
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: KDE 16.12 for Leap 42.2 ?

Wolfgang Bauer
Am Sonntag, 25. Dezember 2016, 19:29:13 schrieb Martin Koller:
> can that package also be updated, please ?

No.

As can be seen in the part of the logfile you posted, kmail 16.12 (and the
other parts of kdepim) requires at least KDE Frameworks 5.28 (the whole stack,
not just extra-cmake-modules).
But Leap 42.2 only has 5.26...

The only way to provide kdepim 16.12 packages (and also others like konqueror)
for Leap 42.2 would be to build against KDE:Frameworks5.

This in turn would mean that users would have to add KDE:Frameworks5 and
KDE:Qt5 too and do a full switch to those repos to be able to use
KDE:Applications.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]