Google Earth busted - 12.2

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Google Earth busted - 12.2

James Knott
After installing 12.2, Google Earth no longer works.  When I try
starting it from the command line, I get the error:

"./googleearth-bin: error while loading shared libraries: libGL.so.1:
cannot open shared object file: No such file or directory"

That library is apparently installed as part of Mesa-libGL1, which is
installed.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Francesco Teodori
google-earth is a 32 bit application. If you system is a 64 bit one,
ypu need to install the 32 bit compatibility packages of mesa libs
regards,
   Francesco

On Wed, Sep 19, 2012 at 1:55 PM, James Knott <[hidden email]> wrote:

>
> After installing 12.2, Google Earth no longer works.  When I try starting
> it from the command line, I get the error:
>
> "./googleearth-bin: error while loading shared libraries: libGL.so.1:
> cannot open shared object file: No such file or directory"
>
> That library is apparently installed as part of Mesa-libGL1, which is
> installed.
>
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>



--
There is a theory which states that if ever anyone discovers exactly what
the Universe is for and why it is here, it will instantly disappear and be
replaced by something even more bizarre and inexplicable. There is another
theory which states that this has already happened.
            -- Douglas Adams, "The Hitchhiker's Guide to the Galaxy"
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

James Knott
Francesco Teodori wrote:
> google-earth is a 32 bit application. If you system is a 64 bit one,
> ypu need to install the 32 bit compatibility packages of mesa libs
> regards,

I installed the 64 bit version.  You can download Googe Earth in 32 & 64
bit and rpm & deb formats.  Regardless, it was running fine on 12.1 and
broke with 12.2.  Even re-installing didn't help.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Patrick Shanahan-2
In reply to this post by James Knott
* James Knott <[hidden email]> [09-19-12 07:58]:
> After installing 12.2, Google Earth no longer works.  When I try starting it
> from the command line, I get the error:
>
> "./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot
> open shared object file: No such file or directory"
>
> That library is apparently installed as part of Mesa-libGL1, which is
> installed.

openSUSE 12.2_Tumbleweed
x86_64 i7
no swap
nvidia 304.32
google-earth-stable-6.0.3.2197-0.x86_64


confirm problem with google-earth-stable but cannot provide command-line
error msgs, crashes X.

forced pkg reinstall w/o change in result.

--
(paka)Patrick Shanahan       Plainfield, Indiana, USA      HOG # US1244711
http://wahoo.no-ip.org        Photo Album: http://wahoo.no-ip.org/gallery2
http://en.opensuse.org                           openSUSE Community Member
Registered Linux User #207535                    @ http://linuxcounter.net
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Marcus Meissner
In reply to this post by James Knott
On Wed, Sep 19, 2012 at 08:16:35AM -0400, James Knott wrote:
> Francesco Teodori wrote:
>> google-earth is a 32 bit application. If you system is a 64 bit one,
>> ypu need to install the 32 bit compatibility packages of mesa libs
>> regards,
>
> I installed the 64 bit version.  You can download Googe Earth in 32 & 64
> bit and rpm & deb formats.  Regardless, it was running fine on 12.1 and
> broke with 12.2.  Even re-installing didn't help.

Did you install Mesa-32bit ... which has libGL.so.1 ?

Ciao, Marcus
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Vadym Krevs
In reply to this post by James Knott
On 19/09/12 12:55, James Knott wrote:
> After installing 12.2, Google Earth no longer works.  When I try
> starting it from the command line, I get the error:
>
> "./googleearth-bin: error while loading shared libraries: libGL.so.1:
> cannot open shared object file: No such file or directory"
>
> That library is apparently installed as part of Mesa-libGL1, which is
> installed.
>
Works just fine on my 12.2. Make sure you have a 32-bit libGL.so.1.

$ ldd  /opt/google/earth/free/googleearth-bin | grep libGL
         libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf64c4000)
         libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf644e000)

$ rpm -qf /usr/X11R6/lib/libGL.so.1
x11-video-nvidiaG02-304.43-20.1.x86_64


--
Regards,
Vadym Krevs

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Francesco Teodori
In reply to this post by James Knott
It means that you have installed google-earth packaged for opensuse
x86_64, however it is a 32 bit application. Install the 32 bit
compatibility packages (i.e. the packages with -32bit extension)
regards,
  Francesco

On Wed, Sep 19, 2012 at 2:16 PM, James Knott <[hidden email]> wrote:

> Francesco Teodori wrote:
>>
>> google-earth is a 32 bit application. If you system is a 64 bit one,
>> ypu need to install the 32 bit compatibility packages of mesa libs
>> regards,
>
>
> I installed the 64 bit version.  You can download Googe Earth in 32 & 64 bit
> and rpm & deb formats.  Regardless, it was running fine on 12.1 and broke
> with 12.2.  Even re-installing didn't help.
>
>
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
>



--
There is a theory which states that if ever anyone discovers exactly
what the Universe is for and why it is here, it will instantly
disappear and be replaced by something even more bizarre and
inexplicable. There is another theory which states that this has
already happened.
            -- Douglas Adams, "The Hitchhiker's Guide to the Galaxy"
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Vadym Krevs
In reply to this post by Vadym Krevs
On 19/09/12 14:03, Vadym Krevs wrote:

> On 19/09/12 12:55, James Knott wrote:
>> After installing 12.2, Google Earth no longer works.  When I try
>> starting it from the command line, I get the error:
>>
>> "./googleearth-bin: error while loading shared libraries: libGL.so.1:
>> cannot open shared object file: No such file or directory"
>>
>> That library is apparently installed as part of Mesa-libGL1, which is
>> installed.
>>
> Works just fine on my 12.2. Make sure you have a 32-bit libGL.so.1.
>
> $ ldd  /opt/google/earth/free/googleearth-bin | grep libGL
>         libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf64c4000)
>         libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf644e000)
>
> $ rpm -qf /usr/X11R6/lib/libGL.so.1
> x11-video-nvidiaG02-304.43-20.1.x86_64
>
>
$ rpm -qf /opt/google/earth/free/googleearth-bin
google-earth-stable-6.0.3.2197-0.x86_64

$ file /opt/google/earth/free/googleearth-bin
/opt/google/earth/free/googleearth-bin: ELF 32-bit LSB executable, Intel
80386, version 1 (SYSV), dynamically linked (uses shared libs), for
GNU/Linux 2.6.15,
BuildID[sha1]=0xc92df1ec77399e133d914554ae0bc5e61a6d8a90, stripped

--
Regards,
Vadym Krevs

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

ellanios82
In reply to this post by Marcus Meissner
On 09/19/2012 03:45 PM, Marcus Meissner wrote:
> Did you install Mesa-32bit ... which has libGL.so.1 ?
_______

  - have installed SuSE 12.2 - Tumbleweed

  - google-earth rpm :

google-earth-stable-6.0.3.2197-0.i386

...........

presently works ok

..........

best regards

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

James Knott
In reply to this post by Marcus Meissner
Marcus Meissner wrote:
> Did you install Mesa-32bit ... which has libGL.so.1 ?

Does the 64 bit version require 32 bit libraries?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

James Knott
In reply to this post by Francesco Teodori
Francesco Teodori wrote:
> It means that you have installed google-earth packaged for opensuse
> x86_64, however it is a 32 bit application. Install the 32 bit
> compatibility packages (i.e. the packages with -32bit extension)
> regards,

I have installed that 32 bit lib.  It appears to fix the problem with
Earth and also Google Talk.  Why didn't the install catch that?  I have
installed those on early versions of openSUSE and not encountered this
problem before.

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Google Earth busted - 12.2

Philipp Thomas-3
In reply to this post by Vadym Krevs
On Wed, 19 Sep 2012 14:22:43 +0100, Vadym Krevs <[hidden email]>
wrote:

>$ rpm -qf /opt/google/earth/free/googleearth-bin
>google-earth-stable-6.0.3.2197-0.x86_64
>
>$ file /opt/google/earth/free/googleearth-bin
>/opt/google/earth/free/googleearth-bin: ELF 32-bit LSB executable,

So the one who packaged googleearth obviously had no clue.

Philipp
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]