Currently no fglrx for factory?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Currently no fglrx for factory?

Joerg Mayer
Hello,

I just updated my experimental laptop to current factory and fglrx to
8.27.10. It seems that I currently can't get the fglrx to work:
When I run --buildpkg for 10.1, it complains that
"module ABI majore versoin (0) doesn't match the server's version(1)",
when I build for 10.2, i complains that
"... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"

Maybe it would be a good idea to make sure that this doesn't find its
way into the Alpha3. Also, is there a way to work around this?

ciao
     Joerg
--
Joerg Mayer                                           <[hidden email]>
We are stuck with technology when what we really want is just stuff that
works. Some say that should read Microsoft instead of technology.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Stefan Dirsch
On Wed, Aug 09, 2006 at 02:20:08PM +0200, Joerg Mayer wrote:

> Hello,
>
> I just updated my experimental laptop to current factory and fglrx to
> 8.27.10. It seems that I currently can't get the fglrx to work:
> When I run --buildpkg for 10.1, it complains that
> "module ABI majore versoin (0) doesn't match the server's version(1)",
> when I build for 10.2, i complains that
> "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
>
> Maybe it would be a good idea to make sure that this doesn't find its
> way into the Alpha3. Also, is there a way to work around this?

Use --buildpkg for 10.2 instead.

Best regards,
Stefan

Public Key available
------------------------------------------------------
Stefan Dirsch (Res. & Dev.)   SUSE LINUX Products GmbH
Tel: 0911-740 53 0            Maxfeldstraße 5
FAX: 0911-740 53 479          D-90409 Nürnberg
http://www.suse.de            Germany
------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Joerg Mayer
On Wed, Aug 09, 2006 at 02:32:06PM +0200, Stefan Dirsch wrote:

> On Wed, Aug 09, 2006 at 02:20:08PM +0200, Joerg Mayer wrote:
> > Hello,
> >
> > I just updated my experimental laptop to current factory and fglrx to
> > 8.27.10. It seems that I currently can't get the fglrx to work:
> > When I run --buildpkg for 10.1, it complains that
> > "module ABI majore versoin (0) doesn't match the server's version(1)",
> > when I build for 10.2, i complains that
> > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
> >
> > Maybe it would be a good idea to make sure that this doesn't find its
> > way into the Alpha3. Also, is there a way to work around this?
>
> Use --buildpkg for 10.2 instead.

> > when I build for 10.2, i complains that
> > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"

Sorry that I wrote that in a hard to understand way.

 Ciao
     Joerg
--
Joerg Mayer                                           <[hidden email]>
We are stuck with technology when what we really want is just stuff that
works. Some say that should read Microsoft instead of technology.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Stefan Dirsch
On Wed, Aug 09, 2006 at 02:37:50PM +0200, Joerg Mayer wrote:

> On Wed, Aug 09, 2006 at 02:32:06PM +0200, Stefan Dirsch wrote:
> > On Wed, Aug 09, 2006 at 02:20:08PM +0200, Joerg Mayer wrote:
> > > Hello,
> > >
> > > I just updated my experimental laptop to current factory and fglrx to
> > > 8.27.10. It seems that I currently can't get the fglrx to work:
> > > When I run --buildpkg for 10.1, it complains that
> > > "module ABI majore versoin (0) doesn't match the server's version(1)",
> > > when I build for 10.2, i complains that
> > > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
> > >
> > > Maybe it would be a good idea to make sure that this doesn't find its
> > > way into the Alpha3. Also, is there a way to work around this?
> >
> > Use --buildpkg for 10.2 instead.
>
> > > when I build for 10.2, i complains that
> > > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
>
> Sorry that I wrote that in a hard to understand way.

Sorry, I didn't read carefully. Factory already uses X.Org "7.1.99.2".
How this is translated to "7.2.-1.2" only ATI knows. :-) Anyway, you
need a newer driver, which is simply not available yet. :-(

No, I don't know when it will be available. Probably after X.Org 7.2
has been released.

Best regards,
Stefan

Public Key available
------------------------------------------------------
Stefan Dirsch (Res. & Dev.)   SUSE LINUX Products GmbH
Tel: 0911-740 53 0            Maxfeldstraße 5
FAX: 0911-740 53 479          D-90409 Nürnberg
http://www.suse.de            Germany
------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Dominique Leuenberger-2
In reply to this post by Joerg Mayer
>>> [hidden email] 09-08-2006 15:20:08 >>>
>Hello,
>
>I just updated my experimental laptop to current factory and fglrx to
>8.27.10. It seems that I currently can't get the fglrx to work:
>When I run --buildpkg for 10.1, it complains that
>"module ABI majore versoin (0) doesn't match the server's
version(1)",
>when I build for 10.2, i complains that
>"... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
>
>Maybe it would be a good idea to make sure that this doesn't find its
>way into the Alpha3. Also, is there a way to work around this?
>

Hi,
 
maybe you can fake it with
 export X_VERSION=x700
in front of the buildpkg command.
 
trying to fake the detected version.


Greetings,
Dominique

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Joerg Mayer
In reply to this post by Stefan Dirsch
On Wed, Aug 09, 2006 at 02:47:26PM +0200, Stefan Dirsch wrote:
> > > > When I run --buildpkg for 10.1, it complains that
> > > > "module ABI majore versoin (0) doesn't match the server's version(1)",
> > > > when I build for 10.2, i complains that
> > > > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
> > > >
> > > > Maybe it would be a good idea to make sure that this doesn't find its
> > > > way into the Alpha3. Also, is there a way to work around this?

OK, so no factory and Alpha > 2 for people with ATI X1xxx cards for now
(my "production" laptop) and no fglrx for the testbed laptop with X300
either.
Why the X300 doesn't work with non-proprietary drivers is left as an
exercise to the writer, if I find the time to play some more :)

 Ciao
      Joerg
--
Joerg Mayer                                           <[hidden email]>
We are stuck with technology when what we really want is just stuff that
works. Some say that should read Microsoft instead of technology.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Joerg Mayer
In reply to this post by Dominique Leuenberger-2
On Wed, Aug 09, 2006 at 03:24:39PM +0200, Dominique Leuenberger wrote:
>  
> maybe you can fake it with
>  export X_VERSION=x700
> in front of the buildpkg command.
>  
> trying to fake the detected version.

In both cases (10.1 and 10.2): no, the messages haven't changed at all.
The ABI version (10.1) would remain incompatible in any case, but the
7.2.-1.2 message is the same too.

Thanks!
       Joerg
--
Joerg Mayer                                           <[hidden email]>
We are stuck with technology when what we really want is just stuff that
works. Some say that should read Microsoft instead of technology.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Currently no fglrx for factory?

Stefan Dirsch
In reply to this post by Joerg Mayer
On Wed, Aug 09, 2006 at 03:37:21PM +0200, Joerg Mayer wrote:

> On Wed, Aug 09, 2006 at 02:47:26PM +0200, Stefan Dirsch wrote:
> > > > > When I run --buildpkg for 10.1, it complains that
> > > > > "module ABI majore versoin (0) doesn't match the server's version(1)",
> > > > > when I build for 10.2, i complains that
> > > > > "... - detected X.org 7.2.-1.2, required X.org 7.1.0.0"
> > > > >
> > > > > Maybe it would be a good idea to make sure that this doesn't find its
> > > > > way into the Alpha3. Also, is there a way to work around this?
>
> OK, so no factory and Alpha > 2 for people with ATI X1xxx cards for now
> (my "production" laptop) and no fglrx for the testbed laptop with X300
> either.

Bug #198125

Best regards,
Stefan

Public Key available
------------------------------------------------------
Stefan Dirsch (Res. & Dev.)   SUSE LINUX Products GmbH
Tel: 0911-740 53 0            Maxfeldstraße 5
FAX: 0911-740 53 479          D-90409 Nürnberg
http://www.suse.de            Germany
------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]