Building for SLE-15

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Building for SLE-15

Wolfgang Engel
Hi,

I'm trying to build a package for SLE-15 but currently it fails with the following error:


package build was not possible:  
no compliant workers (constraints mismatch hint: hostlabel)  
Please adapt your constraints.  


I'm not aware of any constraints I have to adjust there...

This is the package:

https://build.opensuse.org/package/show/home:bigironman:Backports:SLE-15/tmux

Should building for SLE-15 currently work in general in OBS ?

Thanks,

Wolfgang
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Adrian Schröter
On Dienstag, 5. Dezember 2017, 11:43:36 CET wrote [hidden email]:
> Hi,
>
> I'm trying to build a package for SLE-15 but currently it fails with the following error:
>
>
> package build was not possible:  
> no compliant workers (constraints mismatch hint: hostlabel)  
> Please adapt your constraints.  

There were some wrong constraints in the SUSE:SLE-15:GA project, fixed now.

--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Marco Strigl
In reply to this post by Wolfgang Engel
Hi,

On 12/05/2017 11:43 AM, [hidden email] wrote:

> Hi,
>
> I'm trying to build a package for SLE-15 but currently it fails with the following error:
>
>
> package build was not possible:  
> no compliant workers (constraints mismatch hint: hostlabel)  
> Please adapt your constraints.  
>
>
> I'm not aware of any constraints I have to adjust there...
>

Adrian and I took a look at the problem.

> This is the package:
>
> https://build.opensuse.org/package/show/home:bigironman:Backports:SLE-15/tmux
>
> Should building for SLE-15 currently work in general in OBS ?

Yes it should work and works again. Please retrigger the build.

>
> Thanks,
>
> Wolfgang
>

Kind regards,
Marco

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Wolfgang Engel
Perfect, it's building now :)

Thanks!

Wolfgang

December 5, 2017 12:55 PM, "Marco Strigl" <[hidden email]> wrote:

> Hi,
>
> On 12/05/2017 11:43 AM, [hidden email] wrote:
>
>> Hi,
>>
>> I'm trying to build a package for SLE-15 but currently it fails with the following error:
>>
>> package build was not possible:
>> no compliant workers (constraints mismatch hint: hostlabel)
>> Please adapt your constraints.
>>
>> I'm not aware of any constraints I have to adjust there...
>
> Adrian and I took a look at the problem.
>
>> This is the package:
>>
>> https://build.opensuse.org/package/show/home:bigironman:Backports:SLE-15/tmux
>>
>> Should building for SLE-15 currently work in general in OBS ?
>
> Yes it should work and works again. Please retrigger the build.
>
>> Thanks,
>>
>> Wolfgang
>
> Kind regards,
> Marco
>
> --
> To unsubscribe, e-mail: [hidden email]
> To contact the owner, e-mail: [hidden email]
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Olaf Hering-2
In reply to this post by Adrian Schröter
On Tue, Dec 05, Adrian Schröter wrote:

> There were some wrong constraints in the SUSE:SLE-15:GA project, fixed now.

What are the current constraints? Building against either prj results in
pkgs being in state 'scheduled', with no reason shown why no pkg starts
building. Building against Leap15 happens to work.

Olaf

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Adrian Schröter
On Donnerstag, 7. Dezember 2017, 11:19:23 CET wrote Olaf Hering:
> On Tue, Dec 05, Adrian Schröter wrote:
>
> > There were some wrong constraints in the SUSE:SLE-15:GA project, fixed now.
>
> What are the current constraints? Building against either prj results in
> pkgs being in state 'scheduled', with no reason shown why no pkg starts
> building. Building against Leap15 happens to work.

Can you please provide a link when you claim something?

you can use "osc checkconstraints" for finding out which workers
qualify. There must be at least one given that it is in scheduled.

--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Olaf Hering-2
On Thu, Dec 07, Adrian Schröter wrote:

> you can use "osc checkconstraints" for finding out which workers
> qualify. There must be at least one given that it is in scheduled.

This does not seem to work:
pmbs/Essentials/build-compare $ osc checkconstraints --ignore-file
Server returned an error: HTTP Error 404: Not Found

And another pkg which has a _constraints file:
pmbs/Extra/oce $ osc checkconstraints openSUSE_Leap_42.2 x86_64 _constraints
Server returned an error: HTTP Error 404: Not Found

Looks like the buildservice itself is not prepared for SLE_15.

Olaf

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Adrian Schröter
On Donnerstag, 7. Dezember 2017, 11:43:24 CET wrote Olaf Hering:
> On Thu, Dec 07, Adrian Schröter wrote:
>
> > you can use "osc checkconstraints" for finding out which workers
> > qualify. There must be at least one given that it is in scheduled.
>
> This does not seem to work:
> pmbs/Essentials/build-compare $ osc checkconstraints --ignore-file
> Server returned an error: HTTP Error 404: Not Found

pmbs ... seems they are not on OBS 2.8 yet.

> And another pkg which has a _constraints file:
> pmbs/Extra/oce $ osc checkconstraints openSUSE_Leap_42.2 x86_64 _constraints
> Server returned an error: HTTP Error 404: Not Found
>
> Looks like the buildservice itself is not prepared for SLE_15.

nah, that is independend of that.

But you are on the wrong mailing list, if this is not about build.opensuse.org ;)

--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building for SLE-15

Andreas Schwab
In reply to this post by Olaf Hering-2
On Dez 07 2017, Olaf Hering <[hidden email]> wrote:

> What are the current constraints? Building against either prj results in
> pkgs being in state 'scheduled', with no reason shown why no pkg starts
> building. Building against Leap15 happens to work.

When it's stuck in scheduled state then it's not because of constraints
(otherwise you would get a "waiting for compliant worker" message).
Wait and see.

Andreas.

--
Andreas Schwab, [hidden email]
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]