Building Tumbleweed image in OBS

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Tumbleweed image in OBS

opensuse.lietuviu.kalba
Hi,

Can you please help to resolve dependencies while building kiwi image in
OBS for openSUSE Tumbleweed:

"have choice for kiwi-packagemanager:zypper: kiwi-requires python2-kiwi
python3-kiwi"

Adding explicitly in config.kiwi <package name="kiwi-requires"/> or
<package name="python2-kiwi"/> or <package name="python3-kiwi"/> – does
not help...

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building Tumbleweed image in OBS

Frank Schreiner-2
Am Mittwoch, 27. September 2017, 07:32:40 CEST schrieb
opensuse.lietuviu.kalba:

> "have choice for kiwi-packagemanager:zypper: kiwi-requires python2-kiwi
> python3-kiwi"
>
> Adding explicitly in config.kiwi <package name="kiwi-requires"/> or
> <package name="python2-kiwi"/> or <package name="python3-kiwi"/> – does
> not help...

I would try a de-prefer in the project config, e.g.

Prefer: -python2-kiwi

cheers
Frank

signature.asc (201 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building Tumbleweed image in OBS

Adrian Schröter
On Mittwoch, 27. September 2017, 07:54:40 CEST wrote Frank Schreiner:

> Am Mittwoch, 27. September 2017, 07:32:40 CEST schrieb
> opensuse.lietuviu.kalba:
>
> > "have choice for kiwi-packagemanager:zypper: kiwi-requires python2-kiwi
> > python3-kiwi"
> >
> > Adding explicitly in config.kiwi <package name="kiwi-requires"/> or
> > <package name="python2-kiwi"/> or <package name="python3-kiwi"/> – does
> > not help...
>
> I would try a de-prefer in the project config, e.g.
>
> Prefer: -python2-kiwi

Yes, but this should be done in factory as default actually.

No need to configure this in evey project again.

Dominique, can you take care of this?

--

Adrian Schroeter
email: [hidden email]

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
 
Maxfeldstraße 5                        
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Building Tumbleweed image in OBS

opensuse.lietuviu.kalba
In reply to this post by Frank Schreiner-2
2017.09.27 08:54, Frank Schreiner rašė:
> I would try a de-prefer in the project config, e.g.
>
> Prefer: -python2-kiwi

Thanks, it works now.

But I have another problem:

[   82s] [ DEBUG   ]: 07:04:21 | EXEC: [jing /usr/lib/python3.6/site-packages/kiwi/schema/kiwi.rng /tmp/tmpqjplijhh]
[   82s] [ DEBUG   ]: 07:04:21 | "jing": in paths "/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin" exists: "False" mode match: not checked
[   82s] [ DEBUG   ]: 07:04:21 | EXEC: Command "jing" not found in the environment
[   82s] [ INFO    ]: 07:04:21 | RelaxNG validation failed. See jing report:
[   82s] [ INFO    ]: 07:04:21 | --> None
[   82s] [ ERROR   ]: 07:04:21 | KiwiDescriptionInvalid: Schema validation for /usr/src/packages/SOURCES/config.xml failed

Adding <package name="jing"/> in config.kiwi does not help. Can you please help to resolve it?

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]