Build result state not updating

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Build result state not updating

Florian Riedl
Hi everybody.

The rsyslog project is currently trying out OBS to transition to this
build environment in the future. So far, getting into the system is
working well.

But, since yesterday I am observing a strange behaviour with the
builds. When I did my first steps last week, the schedulers were
usually quick to update the state of a build. But yesterday, this
seems to not work correctly anymore. What I observed was that
yesterday the scheduler would only initiate the build for the ppc64
architecture, but not for i586 or x86_64 builds. I wasn't thinking
much of it.

But today the i586 builds seem to be "succeeded" according to the
status and x64 builds are finished, but not yet succeeded.

The question is now: Is this a known problem? Is the scheduler just
"hanging"? Can I do something about this?

Interesting note: While writing this, I decided to trigger one rebuild
and suddenly all the states switched to "succeeded". So, it looks like
something was actually locked up somehow. Still, the questions stay
the same. Any insight you guys can provide is much appreciated.

Regards,
Florian
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Build result state not updating

Tobias Klausmann

On 1/24/18 3:59 PM, Florian Riedl wrote:

> Hi everybody.
>
> The rsyslog project is currently trying out OBS to transition to this
> build environment in the future. So far, getting into the system is
> working well.
>
> But, since yesterday I am observing a strange behaviour with the
> builds. When I did my first steps last week, the schedulers were
> usually quick to update the state of a build. But yesterday, this
> seems to not work correctly anymore. What I observed was that
> yesterday the scheduler would only initiate the build for the ppc64
> architecture, but not for i586 or x86_64 builds. I wasn't thinking
> much of it.
>
> But today the i586 builds seem to be "succeeded" according to the
> status and x64 builds are finished, but not yet succeeded.
>
> The question is now: Is this a known problem? Is the scheduler just
> "hanging"? Can I do something about this?
>
> Interesting note: While writing this, I decided to trigger one rebuild
> and suddenly all the states switched to "succeeded". So, it looks like
> something was actually locked up somehow. Still, the questions stay
> the same. Any insight you guys can provide is much appreciated.
>
> Regards,
> Florian


Hi Florian,

the schedulers for x86_64 and i586 are working fine: For example,
yesterday around 20:00 there were around 20 project updates to schedule
for ppc64, 15.000+ for i586 and 30.000+ for x86_64. With this you can
already guess the outcome: All schedulers are working, yet some have
more work to do and so your project has to wait long for it to get
updated and rescheduled, see https://build.opensuse.org/monitor

Greetings,

Tobias

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Build result state not updating

Andreas Schwab-2
On Jan 24 2018, Tobias Klausmann <[hidden email]> wrote:

> the schedulers for x86_64 and i586 are working fine: For example,
> yesterday around 20:00 there were around 20 project updates to schedule
> for ppc64, 15.000+ for i586 and 30.000+ for x86_64. With this you can
> already guess the outcome: All schedulers are working, yet some have more
> work to do and so your project has to wait long for it to get updated and
> rescheduled, see https://build.opensuse.org/monitor

If you look at the bottom right graph, there are only very few packages
ready to build since 04:00.  That isn't normal.

Andreas.

--
Andreas Schwab, SUSE Labs, [hidden email]
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Build result state not updating

Florian Riedl
Thank you for your replies.

It seems what Andreas pointed out was true. In the meantime, this
seems to be resolved though.

Florian

2018-01-24 17:59 GMT+01:00 Andreas Schwab <[hidden email]>:

> On Jan 24 2018, Tobias Klausmann <[hidden email]> wrote:
>
>> the schedulers for x86_64 and i586 are working fine: For example,
>> yesterday around 20:00 there were around 20 project updates to schedule
>> for ppc64, 15.000+ for i586 and 30.000+ for x86_64. With this you can
>> already guess the outcome: All schedulers are working, yet some have more
>> work to do and so your project has to wait long for it to get updated and
>> rescheduled, see https://build.opensuse.org/monitor
>
> If you look at the bottom right graph, there are only very few packages
> ready to build since 04:00.  That isn't normal.
>
> Andreas.
>
> --
> Andreas Schwab, SUSE Labs, [hidden email]
> GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE  1748 E4D4 88E3 0EEA B9D7
> "And now for something completely different."
--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]