AW: [security-announce] SUSE-SU-2014:1357-1: important: Security update for openssl1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

AW: [security-announce] SUSE-SU-2014:1357-1: important: Security update for openssl1

hans.paffrath
Hello,

I've got a view questions about this patch:

First: Until now we have an openssl rpm installed with SLES11SP3. This seemed to be a patch for openssl1. Is it just because we are now on openssl.1...... or is openssl1 a alternative package?

Second: In the list of fixed updates we find the poodle leak .... For this you announced a workaround:

https://www.suse.com/support/kb/doc.php?id=7015773

After installing the patch: do we need the workarounds - specially for postfix and apache2 any longer?

Thanks for the information.



Mit freundlichem Gruß
Hans Paffrath

Stadt Köln - Der Oberbürgermeister
Amt für Informationsverarbeitung
Willy-Brandt-Platz 3
50679 Köln

Telefon: 0221/221-26085
Telefax: 0221/221-22845
E-Mail: [hidden email]
Internet: www.stadt-koeln.de





-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]]
Gesendet: Dienstag, 4. November 2014 23:05
An: [hidden email]
Betreff: [security-announce] SUSE-SU-2014:1357-1: important: Security update for openssl1

   SUSE Security Update: Security update for openssl1 ______________________________________________________________________________

Announcement ID:    SUSE-SU-2014:1357-1
Rating:             important
References:         #901223 #901277
Cross-References:   CVE-2014-3513 CVE-2014-3566 CVE-2014-3567
                    CVE-2014-3568
Affected Products:
                    SUSE Linux Enterprise Security Module 11 SP3 ______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:


   This OpenSSL update fixes the following issues:

       * SRTP Memory Leak (CVE-2014-3513)
       * Session Ticket Memory Leak (CVE-2014-3567)
       * Build option no-ssl3 is incomplete (CVE-2014-3568)
       * Add support for TLS_FALLBACK_SCSV to mitigate CVE-2014-3566 (POODLE)

   Security Issues:

       * CVE-2014-3513
         <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3513>
       * CVE-2014-3567
         <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3567>
       * CVE-2014-3566
         <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3566>
       * CVE-2014-3568
         <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3568>

Indications:

   Everybody should update.

Patch Instructions:

   To install this SUSE Security Update use YaST online_update.
   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Security Module 11 SP3:

      zypper in -t patch secsp3-libopenssl1-devel-9904

   To bring your system up-to-date, use "zypper patch".


Package List:

   - SUSE Linux Enterprise Security Module 11 SP3 (i586 ia64 ppc64 s390x x86_64):

      libopenssl1-devel-1.0.1g-0.22.1
      libopenssl1_0_0-1.0.1g-0.22.1
      openssl1-1.0.1g-0.22.1
      openssl1-doc-1.0.1g-0.22.1

   - SUSE Linux Enterprise Security Module 11 SP3 (ppc64 s390x x86_64):

      libopenssl1_0_0-32bit-1.0.1g-0.22.1

   - SUSE Linux Enterprise Security Module 11 SP3 (ia64):

      libopenssl1_0_0-x86-1.0.1g-0.22.1


References:

   http://support.novell.com/security/cve/CVE-2014-3513.html
   http://support.novell.com/security/cve/CVE-2014-3566.html
   http://support.novell.com/security/cve/CVE-2014-3567.html
   http://support.novell.com/security/cve/CVE-2014-3568.html
   https://bugzilla.suse.com/show_bug.cgi?id=901223
   https://bugzilla.suse.com/show_bug.cgi?id=901277
   http://download.suse.com/patch/finder/?keywords=b73f6fe02c4bdbb47052a845f36d3df3

--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: [security-announce] SUSE-SU-2014:1357-1: important: Security update for openssl1

Thomas Biege
Hi,
the openssl1 package is for a special product (see Affected Products field in the announcement) and not for a common SLE11.

The workarounds are still needed.

HTH
Thomas

On November 5, 2014 7:41:48 AM CET, [hidden email] wrote:
Hello,

I've got a view questions about this patch:

First: Until now we have an openssl rpm installed with SLES11SP3. This seemed to be a patch for openssl1. Is it just because we are now on openssl.1...... or is openssl1 a alternative package?

Second: In the list of fixed updates we find the poodle leak .... For this you announced a workaround:

https://www.suse.com/support/kb/doc.php?id=7015773

After installing the patch: do we need the workarounds - specially for postfix and apache2 any longer?

Thanks for the information.



Mit freundlichem Gruß
Hans Paffrath

Stadt Köln - Der Oberbürgermeister
Amt für Informationsverarbeitung
Willy-Brandt-Platz 3
50679 Köln

Telefon: 0221/221-26085
Telefax: 0221/221-22845
E-Mail: [hidden email]
In ternet: www.stadt-koeln.de





-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]]
Gesendet: Dienstag, 4. November 2014 23:05
An: [hidden email]
Betreff: [security-announce] SUSE-SU-2014:1357-1: important: Security update for openssl1

SUSE Security Update: Security update for openssl1


Announcement ID: SUSE-SU-2014:1357-1
Rating: important
References: #901223 #901277
Cross-References: CVE-2014-3513 CVE-2014-3566 CVE-2014-3567
CVE-2014-3568
Affected Products:
SUSE Linux Enterprise Security Module 11 SP3


An update that fixes four vulnerabilities is now available.

Description:


This OpenSSL update fixes the following issues:

* SRTP Memory Leak (CVE-2014-3513)
* Session Ticket Memory Leak (CVE-2014-3567)
* Build option no-ssl3 is incomplete (CVE-2014-3568)
* Add support for TLS_FALLBACK_SCSV to mitigate CVE-2014-3566 (POODLE)

Security Issues:

* CVE-2014-3513
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3513>
* CVE-2014-3567
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3567>
* CVE-2014-3566
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3566>
* CVE-2014-3568
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3568>

Indications:

Everybody should update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Security Module 11 SP3:

zypper in -t patch secsp3-libopenssl1-devel-9904

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Security Module 11 SP3 (i586 ia64 ppc64 s390x x86_64):

libopenssl1-devel-1.0.1g-0.22.1
libopenssl1_0_0-1.0.1g-0.22.1
openssl1-1.0.1g-0.22.1
openssl1-doc-1.0.1g-0.22.1

- SUSE Linux Enterprise Security Module 11 SP3 (ppc64 s390x x86_64):

libopenssl1_0_0-32bit-1.0.1g-0.22. 1

- SUSE Linux Enterprise Security Module 11 SP3 (ia64):

libopenssl1_0_0-x86-1.0.1g-0.22.1


References:

http://support.novell.com/security/cve/CVE-2014-3513.html
http://support.novell.com/security/cve/CVE-2014-3566.html
http://support.novell.com/security/cve/CVE-2014-3567.html
http://support.novell.com/security/cve/CVE-2014-3568.html
https://bugzilla.suse.com/show_bug.cgi?id=901223
https://bugzilla.suse.com/show_bug.cgi?id=901277
http://download.suse.com/patch/finder/?keywords=b73f6fe02c4bdbb47052a845f36d3df3

--
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

--
To unsubscribe, e-mail: [hidden email]
To contact the owner, e-mail: [hidden email]


--
Thomas Biege <[hidden email]>, Team Leader MaintenanceSecurity, CSSLP
SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB
21284 (AG Nürnberg)